You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by nowaterflow (Mar 8th 2013, 3:52pm)

3 386

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by brknpcs1 (Sep 7th 2011, 10:36pm)

4 387

by Wet_Boots

(Oct 22nd 2011, 1:34pm)

by Terri (Jan 9th 2013, 6:46am)

1 388

by Wet_Boots

(Jan 9th 2013, 11:08am)

by raisbarth (Feb 26th 2012, 9:14am)

0 389

No reply

by d leimer (Jun 14th 2009, 11:45pm)

2 396

by hi.todd

(Jun 19th 2009, 10:24pm)

by Texas_Pete (May 1st 2005, 7:21pm)

1 397

by Wet_Boots

(May 2nd 2005, 2:02am)

by jimmyburg (Nov 19th 2007, 6:27am)

1 399

by hi.todd

(Apr 6th 2008, 5:05pm)

by Bwilson2 (Aug 13th 2013, 10:12pm)

2 400

by mrfixit

(Aug 14th 2013, 12:28pm)

by binki3 (Aug 29th 2005, 10:33am)

3 400

by RidgeRun05

(Aug 30th 2005, 11:16am)

by waboehly (May 1st 2007, 6:51am)

1 401

by Tom

(May 1st 2007, 3:34pm)

Show

Statistics:

437 Threads - 1,665 Posts (average 0.35 Posts per Day)