You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Kpierce (Apr 12th 2013, 10:36pm)

1 471

by Wet_Boots

(Apr 13th 2013, 10:46am)

by RC (Nov 6th 2011, 7:46pm)

2 471

by Wet_Boots

(Nov 7th 2011, 7:57am)

by AdamT (Jun 7th 2012, 12:00pm)

2 472

by AdamT

(Jun 7th 2012, 9:14pm)

by tinkermaniac (Aug 21st 2002, 2:36pm)

1 472

by Rays Sprinklers

(May 17th 2003, 2:51pm)

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 475

by Wet_Boots

(Jun 9th 2013, 8:14pm)

by Oscar S. Ramirez (Mar 21st 2014, 5:28pm)

1 477

by mrfixit

(Mar 22nd 2014, 1:58am)

by torodude (Aug 27th 2004, 12:47pm)

1 477

by SprinklerGuy

(Aug 30th 2004, 8:24am)

by rickthedrummer101 (May 11th 2013, 2:26pm)

1 480

by Wet_Boots

(May 11th 2013, 5:08pm)

by bobspitler (Jun 6th 2011, 7:10am)

1 480

by Mitchgo

(Jun 6th 2011, 9:34pm)

by bcampy1 (Jun 15th 2007, 11:06am)

0 480

No reply

Show

Statistics:

508 Threads - 1,950 Posts (average 0.37 Posts per Day)