You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by raisbarth (Feb 26th 2012, 9:14am)

0 352

No reply

by Terri (Jan 9th 2013, 6:46am)

1 353

by Wet_Boots

(Jan 9th 2013, 11:08am)

by Texas_Pete (May 1st 2005, 7:21pm)

1 354

by Wet_Boots

(May 2nd 2005, 2:02am)

by paterjb (Jan 5th 2004, 7:46am)

5 354

by RVLI

(Jan 6th 2004, 3:16pm)

by Cherrybark (May 20th 2012, 6:22pm)

2 356

by GatorGuy

(May 21st 2012, 9:04am)

by blh (Jun 4th 2011, 12:55pm)

1 357

by Mitchgo

(Jun 4th 2011, 3:32pm)

by binki3 (Aug 29th 2005, 10:33am)

3 359

by RidgeRun05

(Aug 30th 2005, 11:16am)

by Dan Mueller (Sep 15th 2007, 3:45am)

2 360

by Wet_Boots

(Sep 16th 2007, 7:55am)

by BessMan94 (Jun 24th 2013, 8:45pm)

3 361

by mrfixit

(Jun 25th 2013, 8:32pm)

by jimmyburg (Nov 19th 2007, 6:27am)

1 361

by hi.todd

(Apr 6th 2008, 5:05pm)

Show

Statistics:

440 Threads - 1,685 Posts (average 0.36 Posts per Day)