You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by william62949 (Oct 10th 2010, 2:56pm)

1 316

by mrfixit

(Oct 10th 2010, 6:02pm)

by bombertennis (Jul 9th 2005, 3:20pm)

1 317

by Wet_Boots

(Jul 9th 2005, 3:57pm)

by Rmiclette (May 5th 2013, 6:49am)

2 327

by Scott76

(May 5th 2013, 11:41am)

by handan (Nov 30th 2011, 11:30pm)

2 329

by handan

(Dec 2nd 2011, 4:56am)

by DRegs (May 5th 2010, 5:29pm)

1 330

by Wet_Boots

(May 6th 2010, 2:34pm)

by wkneis@optonline.net (Apr 9th 2006, 5:52pm)

3 332

by xpedient

(Jul 2nd 2006, 3:34pm)

by sanddido (Oct 11th 2007, 3:39am)

1 333

by mrfixit

(Oct 11th 2007, 2:03pm)

by bobspitler (Jun 6th 2011, 7:10am)

1 338

by Mitchgo

(Jun 6th 2011, 9:34pm)

by Jrdcpapc (Aug 1st 2007, 6:17am)

1 338

by SprinklerGuy

(Aug 2nd 2007, 12:41am)

by bcampy1 (Jun 15th 2007, 11:06am)

0 339

No reply

Show

Statistics:

461 Threads - 1,706 Posts (average 0.37 Posts per Day)