You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by rspfau (Jun 9th 2011, 6:12pm)

4 531

by Mitchgo

(Jun 9th 2011, 10:08pm)

by RC (Nov 6th 2011, 7:46pm)

2 199

by Wet_Boots

(Nov 7th 2011, 7:57am)

by eddieruko (Jul 29th 2014, 4:52pm)

2 77

by eddieruko

(Jul 30th 2014, 12:31pm)

by Jonas_ (Mar 13th 2012, 9:40am)

10 1,793

by Wet_Boots

(Mar 16th 2012, 8:14am)

by ragtop69 (Oct 12th 2012, 7:11pm)

1 763

by Wet_Boots

(Oct 12th 2012, 10:24pm)

by WS-1 (May 9th 2010, 4:29pm)

28 8,152

by Romeo

(Jun 10th 2014, 3:57am)

by Texas Guy (May 23rd 2006, 5:48pm)

0 628

No reply

by johncdbass (Oct 21st 2006, 10:40am)

7 1,860

by Wet_Boots

(Oct 23rd 2006, 3:40pm)

by dimlach@peoplepc.com (Apr 22nd 2005, 7:51am)

2 514

by The Professor

(May 26th 2005, 9:53pm)

by criceX (May 20th 2011, 9:34pm)

2 383

by criceX

(May 21st 2011, 7:03pm)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)