You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by desmo907 (Aug 28th 2012, 3:54pm)

3 440

by desmo907

(Sep 4th 2012, 8:33am)

by runningfreak (May 25th 2011, 7:32pm)

1 211

by Wet_Boots

(May 25th 2011, 8:29pm)

by boba (Jul 25th 2005, 7:26am)

0 127

No reply

by SteveM099 (Jun 19th 2006, 1:50am)

1 210

by Wet_Boots

(Jun 19th 2006, 6:17am)

by Moggie (Jun 4th 2011, 10:48am)

1 253

by Mitchgo

(Jun 5th 2011, 1:28pm)

by jimmyburg (Nov 19th 2007, 6:27am)

1 347

by hi.todd

(Apr 6th 2008, 5:05pm)

by MJ (Jul 8th 2007, 5:23am)

0 105

No reply

by slugbugblue (Jul 16th 2010, 6:40am)

2 218

by Wet_Boots

(Jul 17th 2010, 9:11am)

by Marvel (Jan 19th 2013, 6:54am)

7 1,001

by Marvel

(Jan 22nd 2013, 7:49pm)

by tbtech24 (Jun 9th 2011, 9:24am)

3 517

by Wet_Boots

(Jun 9th 2011, 10:09am)

Show

Statistics:

438 Threads - 1,664 Posts (average 0.36 Posts per Day)