You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by wjmoore (Aug 1st 2004, 8:04am)

2 1,498

by nestors

(Oct 31st 2004, 1:30pm)

by dwinmac (Sep 4th 2010, 2:42pm)

3 421

by Wet_Boots

(Sep 5th 2010, 2:55pm)

by JimB (Jul 30th 2011, 3:59pm)

1 178

by Wet_Boots

(Jul 30th 2011, 4:53pm)

by pohall@kivexmail.com (May 13th 2006, 9:21am)

1 805

by jmduke7

(Aug 17th 2006, 3:13pm)

by brobinson (Jun 12th 2010, 7:44am)

8 2,112

by Wet_Boots

(Mar 31st 2012, 4:43pm)

by crashxx (Apr 28th 2012, 12:16pm)

4 836

by crashxx

(May 1st 2012, 9:15am)

by John199 (Aug 14th 2011, 3:57pm)

4 747

by hi.todd

(Aug 15th 2011, 7:29pm)

by JeakeVerent (Jun 11th 2011, 8:46pm)

3 2,327

by Mitchgo

(Jun 12th 2011, 2:13pm)

by korangu2004 (Aug 16th 2006, 5:56pm)

3 1,117

by jmduke7

(Aug 17th 2006, 3:00pm)

by pjansen19 (Nov 7th 2011, 4:18pm)

3 696

by mrfixit

(Nov 10th 2011, 4:23am)

Show

Statistics:

460 Threads - 1,705 Posts (average 0.37 Posts per Day)