You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by sprinklerookie (Jun 6th 2006, 5:21am)

1 372

by jmduke7

(Aug 16th 2006, 6:36pm)

by fatelvis00 (Aug 4th 2006, 2:58pm)

1 840

by mrfixit

(Aug 7th 2006, 1:26am)

by Audit (Jun 14th 2006, 2:16am)

1 619

by xpedient

(Jun 25th 2006, 6:27pm)

by SteveM099 (Jun 19th 2006, 1:50am)

1 383

by Wet_Boots

(Jun 19th 2006, 6:17am)

by tabong (Jun 18th 2006, 5:10pm)

1 364

by Wet_Boots

(Jun 19th 2006, 5:44am)

by SteveM099 (Jun 15th 2006, 2:09pm)

1 410

by SteveM099

(Jun 15th 2006, 2:21pm)

by bzook@aol.com (Jun 8th 2006, 1:47pm)

1 557

by Wet_Boots

(Jun 8th 2006, 3:46pm)

by peetey37 (May 22nd 2006, 7:17am)

1 471

by nestors

(May 27th 2006, 5:31pm)

by keitht (Apr 11th 2006, 3:53pm)

1 394

by BSME

(Apr 12th 2006, 5:45am)

by jstanley (Aug 30th 2005, 5:37pm)

1 311

by SprinklerGuy

(Sep 6th 2005, 7:09am)

Show

Statistics:

513 Threads - 1,964 Posts (average 0.37 Posts per Day)