You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by rockypoint (Nov 26th 2012, 6:02pm)

2 494

by mrfixit

(Nov 26th 2012, 7:30pm)

by lalloo (Aug 5th 2012, 11:02am)

2 153

by GatorGuy

(Aug 6th 2012, 9:13am)

by Bonelawr (Jul 29th 2012, 9:45am)

2 163

by Bonelawr

(Jul 29th 2012, 11:38am)

by Lainiest (Jul 2nd 2012, 7:11pm)

2 169

by GatorGuy

(Jul 3rd 2012, 8:00am)

by jrebcarlson (Jun 11th 2012, 5:40pm)

2 503

by GatorGuy

(Jun 12th 2012, 8:36am)

by dse (Jun 8th 2012, 5:58am)

2 320

by Wet_Boots

(Jun 8th 2012, 8:48am)

by AdamT (Jun 7th 2012, 12:00pm)

2 172

by AdamT

(Jun 7th 2012, 9:14pm)

by Katy (Jun 1st 2012, 3:41pm)

2 180

by hi.todd

(Jun 1st 2012, 8:55pm)

by Cherrybark (May 20th 2012, 6:22pm)

2 296

by GatorGuy

(May 21st 2012, 9:04am)

by SpritzCan (Apr 21st 2012, 8:33pm)

2 137

by GatorGuy

(Apr 23rd 2012, 8:47am)

Show

Statistics:

430 Threads - 1,626 Posts (average 0.36 Posts per Day)