You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by PAP (Aug 19th 2015, 10:04am)

1 143

by Wet_Boots

(Aug 19th 2015, 12:15pm)

by fbg (Aug 13th 2015, 4:40pm)

1 128

by Central Irrigation

(Aug 13th 2015, 6:38pm)

by denver9 (Aug 10th 2015, 10:47pm)

3 99

by Wet_Boots

(Aug 12th 2015, 3:44am)

by sijaz (Aug 11th 2015, 12:25am)

3 73

by mrfixit

(Aug 11th 2015, 2:35pm)

by ScorpioTravis (Aug 10th 2015, 1:06pm)

0 61

No reply

by CRASH (Aug 6th 2015, 6:02pm)

3 134

by Wet boots

(Aug 7th 2015, 3:30pm)

by trs (Aug 4th 2015, 7:38pm)

2 109

by Evergreen Sprinkler

(Aug 7th 2015, 1:34pm)

by Evergreen Sprinkler (Aug 4th 2015, 5:43pm)

0 67

No reply

by Jamie (Jul 29th 2015, 6:17pm)

1 83

by mrfixit

(Jul 29th 2015, 11:48pm)

by Sebastian2015 (Jul 28th 2015, 9:27am)

1 99

by Wet_Boots

(Jul 28th 2015, 11:15am)

Show

Statistics:

475 Threads - 1,784 Posts (average 0.36 Posts per Day)