You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by HHicks (Jul 22nd 2011, 4:57pm)

1 689

by Wet_Boots

(Jul 22nd 2011, 6:38pm)

by irar (Jul 11th 2011, 5:27pm)

4 435

by AutomaticSprinklers

(Jul 20th 2011, 8:49pm)

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 469

by Mitchgo

(Jul 19th 2011, 12:34am)

by DAVID LP (Jul 18th 2011, 10:55am)

2 453

by Wet_Boots

(Jul 18th 2011, 12:19pm)

by veidtmeister (Jul 15th 2011, 9:03pm)

1 294

by Wet_Boots

(Jul 15th 2011, 11:06pm)

by Mac54321 (Jul 13th 2011, 10:03am)

1 745

by Wet_Boots

(Jul 13th 2011, 11:30am)

by zipcode (Jul 10th 2011, 5:26pm)

2 283

by Mitchgo

(Jul 11th 2011, 12:24am)

by ncampbel (Jul 1st 2011, 2:15pm)

1 702

by Mitchgo

(Jul 1st 2011, 9:20pm)

by lkc91311 (Jun 26th 2011, 11:25pm)

0 266

No reply

by Val (Jun 17th 2011, 10:57pm)

4 299

by Val

(Jun 18th 2011, 7:07pm)

Show

Statistics:

461 Threads - 1,706 Posts (average 0.37 Posts per Day)