You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by jyd (May 25th 2015, 4:37am)

1 55

by Wet_Boots

(May 25th 2015, 8:12am)

by PabloCruise (May 3rd 2015, 4:28pm)

3 59

by Wet_Boots

(May 4th 2015, 11:53am)

by zsac09 (Jun 8th 2015, 2:57pm)

2 89

by zsac09

(Jun 10th 2015, 3:26pm)

by DJM8507 (Apr 28th 2015, 12:21pm)

0 91

No reply

by EricJRW (May 6th 2015, 8:09pm)

2 95

by EricJRW

(May 7th 2015, 7:04am)

by ASV (May 11th 2015, 6:30am)

1 100

by Wet_Boots

(May 11th 2015, 8:09am)

by 6pack (May 13th 2015, 8:14pm)

1 105

by Wet_Boots

(May 13th 2015, 8:54pm)

by MAG128 (Jun 24th 2015, 5:32pm)

3 118

by Wet_Boots

(Jun 26th 2015, 6:20am)

by hlsrtony (May 26th 2015, 2:28pm)

3 118

by mrfixit

(May 27th 2015, 3:10pm)

by mellow (May 31st 2015, 7:15pm)

4 125

by mrfixit

(Jun 2nd 2015, 4:08pm)

Show

Statistics:

458 Threads - 1,728 Posts (average 0.36 Posts per Day)