You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by LX2 (Jul 16th 2015, 3:14pm)

2 111

by LX2

(Jul 17th 2015, 8:27am)

by jerr7 (May 4th 2015, 4:35pm)

2 113

by jerr7

(May 6th 2015, 11:08am)

by OldBob (Jul 23rd 2015, 7:37am)

1 119

by OldBob

(Jul 23rd 2015, 8:13pm)

by Behan (Jul 17th 2015, 1:38pm)

1 126

by mrfixit

(Jul 17th 2015, 6:45pm)

by Reg1987 (Jul 12th 2015, 7:43pm)

3 134

by Wet_Boots

(Jul 14th 2015, 6:12pm)

by Gilgaretch (Jun 23rd 2015, 8:23pm)

0 136

No reply

by jyd (May 25th 2015, 4:37am)

1 136

by Wet_Boots

(May 25th 2015, 8:12am)

by Roco8823 (Jun 22nd 2015, 11:43pm)

3 137

by mrfixit

(Jun 23rd 2015, 11:44am)

by PabloCruise (May 3rd 2015, 4:28pm)

3 140

by Wet_Boots

(May 4th 2015, 11:53am)

by Jamie (Jul 29th 2015, 6:17pm)

1 148

by mrfixit

(Jul 29th 2015, 11:48pm)

Show

Statistics:

485 Threads - 1,832 Posts (average 0.36 Posts per Day)