You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Brun (Apr 29th 2008, 6:59am)

4 4,196

by hi.todd

(Nov 16th 2011, 4:49pm)

by Greenweenie (Jun 21st 2010, 9:15am)

2 4,110

by Greenweenie

(Jun 22nd 2010, 8:30am)

by JeakeVerent (Jun 11th 2011, 8:46pm)

3 3,913

by Mitchgo

(Jun 12th 2011, 2:13pm)

by badsprinklers (Oct 10th 2007, 4:55pm)

12 3,744

by Wet_Boots

(Apr 27th 2008, 11:09am)

by Rsnic (Jun 17th 2012, 2:10pm)

6 3,645

by Wet_Boots

(Jun 20th 2012, 10:13am)

by chrisrlewis78 (Aug 4th 2011, 6:51pm)

18 3,567

by chrisrlewis78

(Aug 31st 2011, 4:50pm)

by t_shea (Sep 18th 2010, 10:46am)

5 3,329

by Wet_Boots

(Sep 20th 2010, 1:01pm)

by Jonas_ (Mar 13th 2012, 9:40am)

10 3,116

by Wet_Boots

(Mar 16th 2012, 8:14am)

by skimi (May 6th 2008, 12:27am)

5 3,114

by jbsbeach

(Jan 7th 2009, 7:18am)

by Iphis (Jul 14th 2007, 9:10am)

1 3,046

by SprinklerGuy

(Jul 14th 2007, 10:43am)

Show

Statistics:

497 Threads - 1,879 Posts (average 0.36 Posts per Day)