You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by fairplay (Jan 29th 2007, 1:01pm)

9 3,669

by Wet_Boots

(Aug 17th 2009, 7:50pm)

by JA (May 9th 2010, 11:27am)

7 5,087

by Wet_Boots

(May 3rd 2011, 6:55am)

by wrx884 (Apr 22nd 2011, 12:57am)

5 1,479

by Wet_Boots

(Apr 25th 2011, 9:37am)

by Mikeee (Apr 22nd 2007, 9:24am)

2 890

by jmduke7

(Apr 22nd 2007, 2:21pm)

by slemani62 (Jul 29th 2010, 2:56pm)

1 718

by mrfixit

(Jul 29th 2010, 6:35pm)

by dgergits (Aug 29th 2010, 10:02am)

0 470

No reply

by WHomeowner (Jul 24th 2011, 2:16pm)

10 1,945

by PennyInHeels

(Jun 25th 2013, 3:52pm)

by Greenweenie (Jun 21st 2010, 9:15am)

2 3,094

by Greenweenie

(Jun 22nd 2010, 8:30am)

by badsprinklers (Oct 10th 2007, 4:55pm)

12 2,728

by Wet_Boots

(Apr 27th 2008, 11:09am)

by BRL (Jun 13th 2007, 2:03pm)

0 1,598

No reply

Show

Statistics:

438 Threads - 1,679 Posts (average 0.35 Posts per Day)