You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by JimsLawn (Sep 8th 2015, 2:33pm)

0 201

No reply

by PAP (Aug 19th 2015, 10:04am)

2 480

by PAP

(Sep 8th 2015, 9:57am)

by Artie (Sep 2nd 2015, 7:27am)

1 325

by Wet_Boots

(Sep 2nd 2015, 8:10am)

by GT6812 (Aug 28th 2015, 8:40am)

2 358

by GT6812

(Aug 31st 2015, 11:15am)

by mjtalmadge (Sep 11th 2011, 2:30pm)

11 5,919

by wgn1213

(Aug 18th 2015, 1:23pm)

by fbg (Aug 13th 2015, 4:40pm)

1 414

by Central Irrigation

(Aug 13th 2015, 6:38pm)

by denver9 (Aug 10th 2015, 10:47pm)

3 377

by Wet_Boots

(Aug 12th 2015, 3:44am)

by sijaz (Aug 11th 2015, 12:25am)

3 348

by mrfixit

(Aug 11th 2015, 2:35pm)

by ScorpioTravis (Aug 10th 2015, 1:06pm)

0 168

No reply

by CRASH (Aug 6th 2015, 6:02pm)

3 191

by Wet boots

(Aug 7th 2015, 3:30pm)

Show

Statistics:

485 Threads - 1,832 Posts (average 0.36 Posts per Day)