You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by LT87 (May 21st 2014, 11:33am)

3 102

by hi.todd

(May 27th 2014, 1:03pm)

by noquarter (May 24th 2014, 1:22pm)

6 74

by Wet_Boots

(May 26th 2014, 6:22am)

by abcoker (May 9th 2014, 2:43pm)

5 132

by Wet_Boots

(May 23rd 2014, 7:04am)

by SprinklerMaps (Apr 27th 2014, 10:13pm)

0 147

No reply

by andyl (Apr 21st 2014, 8:32pm)

3 114

by Wet_Boots

(Apr 27th 2014, 9:26am)

by JAshburn (Apr 23rd 2014, 10:04pm)

3 93

by Wet_Boots

(Apr 24th 2014, 4:22pm)

by Oscar S. Ramirez (Mar 21st 2014, 5:28pm)

1 149

by mrfixit

(Mar 22nd 2014, 1:58am)

by PerryNZ (Mar 12th 2014, 10:57pm)

5 155

by PerryNZ

(Mar 14th 2014, 12:16am)

by JT (Mar 9th 2014, 8:08pm)

1 146

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by beachdoc (May 19th 2012, 1:37pm)

5 894

by pavelow

(Oct 30th 2013, 9:51pm)

Show

Statistics:

431 Threads - 1,630 Posts (average 0.36 Posts per Day)