You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by DRegs (May 5th 2010, 5:29pm)

1 436

by Wet_Boots

(May 6th 2010, 2:34pm)

by Don_Mousseau (May 15th 2010, 8:44am)

1 761

by mrfixit

(May 15th 2010, 1:03pm)

by Eclectic (May 17th 2010, 2:01pm)

0 261

No reply

by KSknight (Aug 17th 2009, 10:53am)

1 774

by bdbengtsson

(May 21st 2010, 5:27pm)

by Merv (May 1st 2010, 3:44pm)

3 517

by mrfixit

(May 31st 2010, 9:47pm)

by henry2clue (Jun 1st 2010, 7:30pm)

1 1,795

by mrfixit

(Jun 2nd 2010, 2:27am)

by mcsinkus (Jun 4th 2010, 4:35pm)

1 427

by mrfixit

(Jun 4th 2010, 7:49pm)

by Gerrit Van de Haar (Jun 5th 2010, 2:40pm)

3 395

by HooKooDooKu

(Jun 9th 2010, 11:12am)

by Kim (Jun 19th 2010, 6:45am)

1 324

by mrfixit

(Jun 19th 2010, 12:11pm)

by Greenweenie (Jun 21st 2010, 9:15am)

2 3,835

by Greenweenie

(Jun 22nd 2010, 8:30am)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)