You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by tico (Jun 15th 2013, 8:58pm)

0 776

No reply

by irar (Jul 11th 2011, 5:27pm)

4 774

by AutomaticSprinklers

(Jul 20th 2011, 8:49pm)

by Dagobah (Sep 3rd 2015, 3:46pm)

3 771

by Evergreen Sprinkler

(Sep 11th 2015, 9:41am)

by mcclurgjw (Sep 13th 2005, 8:00am)

2 769

by mcclurgjw

(Sep 14th 2005, 6:04am)

by criceX (May 20th 2011, 9:34pm)

2 756

by criceX

(May 21st 2011, 7:03pm)

by 13dwf (Sep 7th 2010, 1:03pm)

4 736

by Wet_Boots

(Sep 9th 2010, 8:50pm)

by Metalman1 (May 23rd 2011, 11:56am)

3 726

by sharon

(May 30th 2011, 12:20pm)

by macminn (Jun 11th 2007, 5:43pm)

2 720

by mrfixit

(Jun 7th 2008, 8:13am)

by AWCiesiel (Jul 13th 2012, 8:42pm)

1 719

by mrfixit

(Jul 14th 2012, 12:39am)

by dkraska (Aug 29th 2009, 2:41pm)

4 719

by hi.todd

(Aug 30th 2009, 9:32pm)

Show

Statistics:

508 Threads - 1,950 Posts (average 0.37 Posts per Day)