You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Island Sprinklers (Mar 12th 2013, 10:47am)

1 377

by Wet_Boots

(Mar 12th 2013, 11:42am)

by India (Mar 17th 2009, 7:07am)

5 377

by HooKooDooKu

(Mar 25th 2009, 10:16pm)

by Fidalgorob (Dec 4th 2010, 12:19pm)

1 376

by mrfixit

(Dec 4th 2010, 1:48pm)

by Max (May 6th 2007, 8:27pm)

2 376

by Tom

(May 9th 2007, 3:29am)

by betsycam (Oct 13th 2013, 4:26pm)

1 375

by Wet_Boots

(Oct 14th 2013, 10:18am)

by sdguy (Mar 10th 2013, 3:15pm)

3 374

by Wet_Boots

(Jul 31st 2013, 10:41am)

by mikesegall@aol.com (Dec 25th 2012, 6:20pm)

1 372

by Wet_Boots

(Dec 26th 2012, 8:32am)

by lydiaE (Jun 25th 2009, 11:39am)

1 370

by HooKooDooKu

(Jul 1st 2009, 11:31am)

by Kevin Dearden (Jun 14th 2003, 4:15am)

6 369

by Rays Sprinklers

(Jul 2nd 2003, 8:52am)

by jeffg (Oct 22nd 2011, 6:06pm)

1 367

by Wet_Boots

(Oct 23rd 2011, 11:52am)

Show

Statistics:

430 Threads - 1,627 Posts (average 0.36 Posts per Day)