You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Dagobah (Sep 3rd 2015, 3:46pm)

3 696

by Evergreen Sprinkler

(Sep 11th 2015, 9:41am)

by wileyb (Mar 23rd 2015, 4:00pm)

2 693

by Wet_Boots

(Mar 24th 2015, 9:18am)

by 13dwf (Sep 7th 2010, 1:03pm)

4 689

by Wet_Boots

(Sep 9th 2010, 8:50pm)

by criceX (May 20th 2011, 9:34pm)

2 686

by criceX

(May 21st 2011, 7:03pm)

by 88goldwing (Sep 1st 2015, 2:28pm)

12 684

by 88goldwing

(Sep 8th 2015, 5:36pm)

by irar (Jul 11th 2011, 5:27pm)

4 673

by AutomaticSprinklers

(Jul 20th 2011, 8:49pm)

by macminn (Jun 11th 2007, 5:43pm)

2 670

by mrfixit

(Jun 7th 2008, 8:13am)

by OscarNav (Apr 17th 2005, 8:54pm)

2 666

by Jazzer K

(Sep 2nd 2005, 6:15pm)

by cassian (Jul 31st 2005, 2:39pm)

4 664

by RidgeRun05

(Aug 1st 2005, 4:58pm)

by Metalman1 (May 23rd 2011, 11:56am)

3 661

by sharon

(May 30th 2011, 12:20pm)

Show

Statistics:

496 Threads - 1,876 Posts (average 0.36 Posts per Day)