You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by irar (Jul 11th 2011, 5:27pm)

4 567

by AutomaticSprinklers

(Jul 20th 2011, 8:49pm)

by Brassguy (Feb 26th 2012, 4:36pm)

5 566

by Brassguy

(Mar 8th 2012, 10:09pm)

by Marlene (Aug 23rd 2007, 3:11am)

4 564

by Marlene

(Aug 25th 2007, 5:42am)

by Metalman1 (May 23rd 2011, 11:56am)

3 562

by sharon

(May 30th 2011, 12:20pm)

by quick11 (Oct 7th 2010, 10:53am)

3 561

by Wet_Boots

(Oct 23rd 2010, 9:10am)

by macminn (Jun 11th 2007, 5:43pm)

2 561

by mrfixit

(Jun 7th 2008, 8:13am)

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 560

by Mitchgo

(Jul 19th 2011, 12:34am)

by Panic1978 (Jul 17th 2009, 6:52pm)

0 560

No reply

by Montgomeryc (Jun 13th 2012, 2:46pm)

1 559

by Wet_Boots

(Jun 13th 2012, 4:03pm)

by OscarNav (Apr 17th 2005, 8:54pm)

2 556

by Jazzer K

(Sep 2nd 2005, 6:15pm)

Show

Statistics:

475 Threads - 1,784 Posts (average 0.36 Posts per Day)