You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Freddyfrom fl (Aug 6th 2013, 6:49pm)

1 159

by Wet_Boots

(Aug 6th 2013, 9:29pm)

by modetz (Jun 16th 2012, 11:23am)

1 195

by Wet_Boots

(Jun 16th 2012, 12:29pm)

by lalloo (Aug 5th 2012, 11:02am)

2 140

by GatorGuy

(Aug 6th 2012, 9:13am)

by abhnoclue (Jun 16th 2007, 10:57am)

2 148

by abhnoclue

(Jun 17th 2007, 6:20am)

by rspfau (Jun 9th 2011, 6:12pm)

4 447

by Mitchgo

(Jun 9th 2011, 10:08pm)

by RC (Nov 6th 2011, 7:46pm)

2 159

by Wet_Boots

(Nov 7th 2011, 7:57am)

by Jonas_ (Mar 13th 2012, 9:40am)

10 1,388

by Wet_Boots

(Mar 16th 2012, 8:14am)

by ragtop69 (Oct 12th 2012, 7:11pm)

1 600

by Wet_Boots

(Oct 12th 2012, 10:24pm)

by WS-1 (May 9th 2010, 4:29pm)

26 6,678

by onkio

(Mar 12th 2014, 2:49pm)

by Texas Guy (May 23rd 2006, 5:48pm)

0 562

No reply

Show

Statistics:

420 Threads - 1,567 Posts (average 0.35 Posts per Day)