You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by bdt (Oct 17th 2011, 9:50am)

2 292

by Mitchgo

(Oct 17th 2011, 12:59pm)

by bron7fan@cox.net (Oct 15th 2011, 5:15pm)

2 112

by mrfixit

(Oct 16th 2011, 2:26am)

by mulletmac (Sep 30th 2011, 7:29am)

2 326

by mulletmac

(Oct 1st 2011, 11:26am)

by patk (Sep 18th 2011, 2:17pm)

2 519

by patk

(Sep 18th 2011, 3:41pm)

by mjtalmadge (Sep 11th 2011, 2:30pm)

2 1,429

by CRI IRR

(Sep 13th 2011, 6:31am)

by tbatrof (Sep 10th 2011, 7:00pm)

2 191

by mrfixit

(Sep 10th 2011, 10:07pm)

by evergreenz (Sep 3rd 2011, 2:33am)

2 114

by evergreenz

(Sep 3rd 2011, 12:08pm)

by horse_98 (Aug 22nd 2011, 4:03pm)

2 96

by Wet_Boots

(Aug 23rd 2011, 11:43am)

by fwoodall (Aug 28th 2005, 6:01pm)

2 745

by squints

(Jul 31st 2011, 2:16pm)

by GeorgeBorge21 (Jul 25th 2011, 1:15pm)

2 256

by Mitchgo

(Jul 25th 2011, 11:12pm)

Show

Statistics:

418 Threads - 1,564 Posts (average 0.35 Posts per Day)