You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by Rendaug (Jan 18th 2004, 12:31pm)

3 376

by Rendaug

(Feb 8th 2004, 10:37am)

by labert (Jan 3rd 2004, 6:11am)

3 1,016

by labert

(Jan 7th 2004, 2:15pm)

by dzuroff (Oct 13th 2003, 7:33am)

3 418

by bhungue2

(Oct 15th 2003, 8:06am)

by Chuck (Jun 29th 2003, 2:59pm)

3 614

by Rays Sprinklers

(Jul 1st 2003, 12:19pm)

by PAP (Aug 19th 2015, 10:04am)

2 300

by PAP

(Sep 8th 2015, 9:57am)

by GT6812 (Aug 28th 2015, 8:40am)

2 204

by GT6812

(Aug 31st 2015, 11:15am)

by trs (Aug 4th 2015, 7:38pm)

2 155

by Evergreen Sprinkler

(Aug 7th 2015, 1:34pm)

by LX2 (Jul 16th 2015, 3:14pm)

2 84

by LX2

(Jul 17th 2015, 8:27am)

by Eowilcox (Jun 18th 2015, 12:20pm)

2 125

by Eowilcox

(Jun 18th 2015, 2:23pm)

by zsac09 (Jun 8th 2015, 2:57pm)

2 162

by zsac09

(Jun 10th 2015, 3:26pm)



479 Threads - 1,805 Posts (average 0.36 Posts per Day)