You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by rickesco (Jul 28th 2004, 8:13am)

3 340

by aquamatic

(Jul 29th 2004, 10:36am)

by Rendaug (Jan 18th 2004, 12:31pm)

3 395

by Rendaug

(Feb 8th 2004, 10:37am)

by labert (Jan 3rd 2004, 6:11am)

3 1,048

by labert

(Jan 7th 2004, 2:15pm)

by dzuroff (Oct 13th 2003, 7:33am)

3 437

by bhungue2

(Oct 15th 2003, 8:06am)

by Chuck (Jun 29th 2003, 2:59pm)

3 642

by Rays Sprinklers

(Jul 1st 2003, 12:19pm)

by PAP (Aug 19th 2015, 10:04am)

2 372

by PAP

(Sep 8th 2015, 9:57am)

by GT6812 (Aug 28th 2015, 8:40am)

2 263

by GT6812

(Aug 31st 2015, 11:15am)

by trs (Aug 4th 2015, 7:38pm)

2 195

by Evergreen Sprinkler

(Aug 7th 2015, 1:34pm)

by LX2 (Jul 16th 2015, 3:14pm)

2 93

by LX2

(Jul 17th 2015, 8:27am)

by Eowilcox (Jun 18th 2015, 12:20pm)

2 150

by Eowilcox

(Jun 18th 2015, 2:23pm)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)