You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Ryanm519 (Jun 16th 2011, 1:28am)

1 429

by Wet_Boots

(Jun 16th 2011, 6:25am)

by pillboy (Jun 8th 2011, 6:40pm)

11 3,320

by Wet_Boots

(Jun 14th 2011, 2:26pm)

by jackh (Jun 12th 2011, 11:57am)

9 2,925

by Wet_Boots

(Jun 13th 2011, 9:17am)

by JeakeVerent (Jun 11th 2011, 8:46pm)

3 2,515

by Mitchgo

(Jun 12th 2011, 2:13pm)

by rspfau (Jun 9th 2011, 6:12pm)

4 670

by Mitchgo

(Jun 9th 2011, 10:08pm)

by Grahpack (Jun 9th 2011, 7:07pm)

1 492

by Wet_Boots

(Jun 9th 2011, 9:05pm)

by tbtech24 (Jun 9th 2011, 9:24am)

3 573

by Wet_Boots

(Jun 9th 2011, 10:09am)

by ddeferra (Jun 7th 2011, 10:46pm)

2 723

by ddeferra

(Jun 8th 2011, 6:29pm)

by bherholz (May 16th 2011, 12:06pm)

5 1,146

by mrfixit

(Jun 7th 2011, 5:46pm)

by bobspitler (Jun 6th 2011, 7:10am)

1 351

by Mitchgo

(Jun 6th 2011, 9:34pm)

Show

Statistics:

437 Threads - 1,665 Posts (average 0.35 Posts per Day)