You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by GraemeDunkley (May 4th 2013, 10:50pm)

5 374

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by dkraska (Aug 29th 2009, 2:41pm)

4 374

by hi.todd

(Aug 30th 2009, 9:32pm)

by 206007075 (Sep 28th 2004, 10:26am)

0 373

No reply

by ros (Mar 15th 2012, 7:40pm)

1 372

by hi.todd

(Mar 20th 2012, 9:07pm)

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 371

by Mitchgo

(Jul 19th 2011, 12:34am)

by Max (May 6th 2007, 8:27pm)

2 371

by Tom

(May 9th 2007, 3:29am)

by Metalman1 (May 23rd 2011, 11:56am)

3 370

by sharon

(May 30th 2011, 12:20pm)

by ruchuck (May 29th 2013, 8:54am)

7 369

by mrfixit

(Jun 2nd 2013, 12:03am)

by Marlene (Aug 23rd 2007, 3:11am)

4 369

by Marlene

(Aug 25th 2007, 5:42am)

by Fidalgorob (Dec 4th 2010, 12:19pm)

1 368

by mrfixit

(Dec 4th 2010, 1:48pm)

Show

Statistics:

430 Threads - 1,625 Posts (average 0.36 Posts per Day)