You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by jchsmiller (Apr 18th 2011, 11:47am)

1 310

by Wet_Boots

(Apr 20th 2011, 12:27pm)

by william62949 (Oct 10th 2010, 2:56pm)

1 313

by mrfixit

(Oct 10th 2010, 6:02pm)

by Rmiclette (May 5th 2013, 6:49am)

2 321

by Scott76

(May 5th 2013, 11:41am)

by DRegs (May 5th 2010, 5:29pm)

1 323

by Wet_Boots

(May 6th 2010, 2:34pm)

by handan (Nov 30th 2011, 11:30pm)

2 324

by handan

(Dec 2nd 2011, 4:56am)

by wkneis@optonline.net (Apr 9th 2006, 5:52pm)

3 325

by xpedient

(Jul 2nd 2006, 3:34pm)

by sanddido (Oct 11th 2007, 3:39am)

1 329

by mrfixit

(Oct 11th 2007, 2:03pm)

by bobspitler (Jun 6th 2011, 7:10am)

1 331

by Mitchgo

(Jun 6th 2011, 9:34pm)

by Jrdcpapc (Aug 1st 2007, 6:17am)

1 331

by SprinklerGuy

(Aug 2nd 2007, 12:41am)

by Stu1986 (May 5th 2012, 11:44pm)

3 332

by mrfixit

(May 6th 2012, 1:23pm)

Show

Statistics:

440 Threads - 1,685 Posts (average 0.36 Posts per Day)