You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by william62949 (Oct 10th 2010, 2:56pm)

1 281

by mrfixit

(Oct 10th 2010, 6:02pm)

by peetey37 (May 22nd 2006, 7:17am)

1 281

by nestors

(May 27th 2006, 5:31pm)

by jchsmiller (Apr 18th 2011, 11:47am)

1 282

by Wet_Boots

(Apr 20th 2011, 12:27pm)

by jimmyburg (Oct 2nd 2007, 7:22am)

0 282

No reply

by nowaterflow (Mar 8th 2013, 3:52pm)

3 283

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by brknpcs1 (Sep 7th 2011, 10:36pm)

4 286

by Wet_Boots

(Oct 22nd 2011, 1:34pm)

by pphilt (Oct 9th 2011, 9:55pm)

5 288

by JimmyTheGlove

(Oct 13th 2011, 3:24pm)

by Ianjanson (Apr 10th 2013, 1:37pm)

2 289

by Ianjanson

(Apr 10th 2013, 7:37pm)

by Stu1986 (May 5th 2012, 11:44pm)

3 289

by mrfixit

(May 6th 2012, 1:23pm)

by wkneis@optonline.net (Apr 9th 2006, 5:52pm)

3 290

by xpedient

(Jul 2nd 2006, 3:34pm)

Show

Statistics:

436 Threads - 1,648 Posts (average 0.36 Posts per Day)