You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by bobspitler (Jun 6th 2011, 7:10am)

1 359

by Mitchgo

(Jun 6th 2011, 9:34pm)

by PerryNZ (Mar 12th 2014, 10:57pm)

5 361

by PerryNZ

(Mar 14th 2014, 12:16am)

by bcampy1 (Jun 15th 2007, 11:06am)

0 362

No reply

by sanddido (Oct 11th 2007, 3:39am)

1 363

by mrfixit

(Oct 11th 2007, 2:03pm)

by DRegs (May 5th 2010, 5:29pm)

1 365

by Wet_Boots

(May 6th 2010, 2:34pm)

by Rmiclette (May 5th 2013, 6:49am)

2 367

by Scott76

(May 5th 2013, 11:41am)

by Jrdcpapc (Aug 1st 2007, 6:17am)

1 368

by SprinklerGuy

(Aug 2nd 2007, 12:41am)

by m collins (Jul 5th 2012, 11:04am)

3 374

by GatorGuy

(Jul 5th 2012, 12:27pm)

by pphilt (Oct 9th 2011, 9:55pm)

5 376

by JimmyTheGlove

(Oct 13th 2011, 3:24pm)

by GeorgeBorge21 (Jul 25th 2011, 1:15pm)

2 380

by Mitchgo

(Jul 25th 2011, 11:12pm)

Show

Statistics:

437 Threads - 1,666 Posts (average 0.35 Posts per Day)