You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by gobris (May 14th 2013, 9:45am)

3 747

by Wet_Boots

(May 16th 2013, 8:30am)

by alscarpati (May 20th 2006, 2:02am)

5 743

by alscarpati

(May 21st 2006, 7:02am)

by RonBLaGrone (Jun 4th 2013, 11:05am)

2 742

by Ronblagrone

(Jun 12th 2013, 10:23pm)

by Jeff Nobles (May 21st 2009, 9:40am)

3 742

by hi.todd

(May 22nd 2009, 8:19pm)

by macminn (May 18th 2007, 5:05pm)

9 740

by SprinklerGuy

(May 25th 2007, 3:19am)

by mcclurgjw (Sep 13th 2005, 8:00am)

2 740

by mcclurgjw

(Sep 14th 2005, 6:04am)

by jzb18134 (Sep 7th 2011, 3:55pm)

6 738

by CRI IRR

(Sep 13th 2011, 6:34am)

by Dagobah (Sep 3rd 2015, 3:46pm)

3 737

by Evergreen Sprinkler

(Sep 11th 2015, 9:41am)

by sdguy (Mar 10th 2013, 3:15pm)

3 737

by Wet_Boots

(Jul 31st 2013, 10:41am)

by 88goldwing (Sep 1st 2015, 2:28pm)

12 727

by 88goldwing

(Sep 8th 2015, 5:36pm)

Show

Statistics:

500 Threads - 1,901 Posts (average 0.37 Posts per Day)