You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Gansmanms (Nov 7th 2012, 9:10pm)

7 1,262

by marian

(Sep 2nd 2013, 5:37pm)

by EtzGx (Jun 21st 2009, 12:40pm)

0 469

No reply

by miker (Apr 30th 2011, 12:53pm)

1 362

by Wet_Boots

(Apr 30th 2011, 2:45pm)

by asegal (Oct 5th 2006, 7:43am)

4 954

by asegal

(Oct 6th 2006, 10:52am)

by KSknight (Aug 17th 2009, 10:53am)

1 646

by bdbengtsson

(May 21st 2010, 5:27pm)

by kenball27 (May 1st 2009, 1:01pm)

3 2,409

by mrfixit

(May 10th 2009, 1:13pm)

by PintoDr (Jun 28th 2012, 11:50pm)

5 606

by Wet_Boots

(Jun 29th 2012, 10:15pm)

by harrisst14 (Jun 10th 2012, 6:29pm)

1 647

by mrfixit

(Jun 10th 2012, 8:13pm)

by rchead755 (Aug 23rd 2014, 11:36am)

2 32

by irrigirl

(Aug 25th 2014, 4:59pm)

by midnight (May 2nd 2006, 6:02pm)

0 259

No reply

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)