You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by kenball27 (May 1st 2009, 1:01pm)

3 2,321

by mrfixit

(May 10th 2009, 1:13pm)

by PintoDr (Jun 28th 2012, 11:50pm)

5 507

by Wet_Boots

(Jun 29th 2012, 10:15pm)

by harrisst14 (Jun 10th 2012, 6:29pm)

1 497

by mrfixit

(Jun 10th 2012, 8:13pm)

by midnight (May 2nd 2006, 6:02pm)

0 234

No reply

by PerryNZ (Mar 12th 2014, 10:57pm)

5 40

by PerryNZ

(Mar 14th 2014, 12:16am)

by garbid (Oct 16th 2005, 7:29am)

5 378

by lush96

(Mar 19th 2006, 8:09pm)

by archiejobs (May 31st 2006, 4:18am)

2 200

by archiejobs

(May 31st 2006, 4:24am)

by bherholz (May 16th 2011, 12:06pm)

5 749

by mrfixit

(Jun 7th 2011, 5:46pm)

by Bill Pajerski (Jun 26th 2009, 8:18am)

1 192

by Wet_Boots

(Jun 26th 2009, 8:58am)

by Sierra9093 (Jul 5th 2011, 8:06pm)

5 396

by s123mith

(Jul 10th 2012, 5:21am)

Show

Statistics:

419 Threads - 1,565 Posts (average 0.35 Posts per Day)