You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by rickesco (Jul 28th 2004, 8:13am)

3 267

by aquamatic

(Jul 29th 2004, 10:36am)

by Rendaug (Jan 18th 2004, 12:31pm)

3 319

by Rendaug

(Feb 8th 2004, 10:37am)

by labert (Jan 3rd 2004, 6:11am)

3 917

by labert

(Jan 7th 2004, 2:15pm)

by dzuroff (Oct 13th 2003, 7:33am)

3 369

by bhungue2

(Oct 15th 2003, 8:06am)

by Chuck (Jun 29th 2003, 2:59pm)

3 535

by Rays Sprinklers

(Jul 1st 2003, 12:19pm)

by EricJRW (May 6th 2015, 8:09pm)

2 75

by EricJRW

(May 7th 2015, 7:04am)

by jerr7 (May 4th 2015, 4:35pm)

2 43

by jerr7

(May 6th 2015, 11:08am)

by fouracreDon (Mar 17th 2015, 8:09am)

2 160

by carlanw

(Apr 27th 2015, 10:52pm)

by wileyb (Mar 23rd 2015, 4:00pm)

2 597

by Wet_Boots

(Mar 24th 2015, 9:18am)

by eddieruko (Jul 29th 2014, 4:52pm)

2 228

by eddieruko

(Jul 30th 2014, 12:31pm)

Show

Statistics:

472 Threads - 1,758 Posts (average 0.36 Posts per Day)