You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by ssherrid (Jul 21st 2010, 12:18am)

0 603

No reply

by slugbugblue (Jul 16th 2010, 6:40am)

2 387

by Wet_Boots

(Jul 17th 2010, 9:11am)

by paul b (Jul 3rd 2010, 10:24am)

1 631

by Wet_Boots

(Jul 6th 2010, 9:21am)

by svsprinklers (May 19th 2010, 9:29pm)

2 1,358

by PhoenixDen

(Jun 24th 2010, 11:27am)

by DRegs (May 5th 2010, 5:29pm)

1 485

by Wet_Boots

(May 6th 2010, 2:34pm)

by BVISailor (Oct 31st 2009, 10:11am)

1 1,151

by worachj

(Oct 31st 2009, 12:47pm)

by stillc (Jul 29th 2009, 12:36pm)

2 968

by Wet_Boots

(Aug 4th 2009, 1:08am)

by lydiaE (Jun 25th 2009, 11:39am)

1 573

by HooKooDooKu

(Jul 1st 2009, 11:31am)

by Bill Pajerski (Jun 26th 2009, 8:18am)

1 468

by Wet_Boots

(Jun 26th 2009, 8:58am)

by Roger Stover (Jun 16th 2009, 11:09am)

4 374

by hi.todd

(Jun 19th 2009, 10:27pm)

Show

Statistics:

500 Threads - 1,903 Posts (average 0.37 Posts per Day)