You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Ryanm519 (Jun 16th 2011, 1:28am)

1 590

by Wet_Boots

(Jun 16th 2011, 6:25am)

by ddeferra (Jun 7th 2011, 10:46pm)

2 1,240

by ddeferra

(Jun 8th 2011, 6:29pm)

by bobspitler (Jun 6th 2011, 7:10am)

1 506

by Mitchgo

(Jun 6th 2011, 9:34pm)

by Moggie (Jun 4th 2011, 10:48am)

1 446

by Mitchgo

(Jun 5th 2011, 1:28pm)

by blh (Jun 4th 2011, 12:55pm)

1 618

by Mitchgo

(Jun 4th 2011, 3:32pm)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 577

by Mitchgo

(May 9th 2011, 1:04am)

by jchsmiller (Apr 18th 2011, 11:47am)

1 488

by Wet_Boots

(Apr 20th 2011, 12:27pm)

by g (Apr 19th 2011, 1:56pm)

0 330

No reply

by orgits (Apr 9th 2011, 5:10pm)

2 1,602

by Mitchgo

(Apr 10th 2011, 2:29am)

by joe decoste (Mar 19th 2011, 11:56am)

1 398

by Wet_Boots

(Mar 20th 2011, 7:29am)

Show

Statistics:

517 Threads - 1,975 Posts (average 0.37 Posts per Day)