You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by d leimer (Jun 14th 2009, 11:45pm)

2 480

by hi.todd

(Jun 19th 2009, 10:24pm)

by Roger Stover (Jun 16th 2009, 11:09am)

4 314

by hi.todd

(Jun 19th 2009, 10:27pm)

by Hammy69 (Jun 16th 2009, 9:46am)

1 310

by hi.todd

(Jun 19th 2009, 10:29pm)

by bbruck (Jun 20th 2009, 7:11pm)

1 488

by Wet_Boots

(Jun 21st 2009, 8:31am)

by EtzGx (Jun 21st 2009, 12:40pm)

0 572

No reply

by Bill Pajerski (Jun 26th 2009, 8:18am)

1 402

by Wet_Boots

(Jun 26th 2009, 8:58am)

by George_S (Jun 26th 2009, 7:13pm)

0 285

No reply

by lydiaE (Jun 25th 2009, 11:39am)

1 504

by HooKooDooKu

(Jul 1st 2009, 11:31am)

by trapkoch (Jul 5th 2009, 10:20am)

1 406

by mrfixit

(Jul 5th 2009, 12:46pm)

by wingnut (Jul 9th 2009, 10:29pm)

1 333

by mrfixit

(Jul 10th 2009, 2:31pm)



479 Threads - 1,805 Posts (average 0.36 Posts per Day)