You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by Sierra9093 (Jul 5th 2011, 8:06pm)

5 696

by s123mith

(Jul 10th 2012, 5:21am)

by pstruh (Jun 7th 2007, 7:58pm)

2 696

by mrfixit

(Jun 8th 2007, 9:45pm)

by alscarpati (May 20th 2006, 2:02am)

5 695

by alscarpati

(May 21st 2006, 7:02am)

by opsec (Apr 1st 2012, 7:44pm)

2 693

by Wet_Boots

(Apr 2nd 2012, 9:08am)

by csnugg (Jun 26th 2006, 4:10pm)

0 693

No reply

by sdguy (Mar 10th 2013, 3:15pm)

3 687

by Wet_Boots

(Jul 31st 2013, 10:41am)

by macminn (May 18th 2007, 5:05pm)

9 681

by SprinklerGuy

(May 25th 2007, 3:19am)

by Island Sprinklers (Mar 12th 2013, 10:47am)

1 675

by Wet_Boots

(Mar 12th 2013, 11:42am)

by gobris (May 14th 2013, 9:45am)

3 671

by Wet_Boots

(May 16th 2013, 8:30am)

by RonBLaGrone (Jun 4th 2013, 11:05am)

2 669

by Ronblagrone

(Jun 12th 2013, 10:23pm)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)