You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by opsec (Apr 1st 2012, 7:44pm)

2 346

by Wet_Boots

(Apr 2nd 2012, 9:08am)

by dkraska (Aug 29th 2009, 2:41pm)

4 346

by hi.todd

(Aug 30th 2009, 9:32pm)

by ros (Mar 15th 2012, 7:40pm)

1 344

by hi.todd

(Mar 20th 2012, 9:07pm)

by Fidalgorob (Dec 4th 2010, 12:19pm)

1 342

by mrfixit

(Dec 4th 2010, 1:48pm)

by denm31 (Apr 4th 2011, 3:11pm)

6 340

by Wet_Boots

(Apr 7th 2011, 1:00pm)

by Max (May 6th 2007, 8:27pm)

2 340

by Tom

(May 9th 2007, 3:29am)

by ddak32@yahoo.com (Oct 17th 2012, 3:09pm)

1 339

by Wet_Boots

(Oct 17th 2012, 5:31pm)

by macminn (Jun 11th 2007, 5:43pm)

2 338

by mrfixit

(Jun 7th 2008, 8:13am)

by 206007075 (Sep 28th 2004, 10:26am)

0 338

No reply

by lydiaE (Jun 25th 2009, 11:39am)

1 337

by HooKooDooKu

(Jul 1st 2009, 11:31am)

Show

Statistics:

419 Threads - 1,565 Posts (average 0.35 Posts per Day)