You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by pjansen19 (Nov 7th 2011, 4:18pm)

3 1,016

by mrfixit

(Nov 10th 2011, 4:23am)

by alf51175 (Aug 1st 2011, 9:53pm)

3 388

by alf51175

(Aug 2nd 2011, 8:02pm)

by JeakeVerent (Jun 11th 2011, 8:46pm)

3 4,045

by Mitchgo

(Jun 12th 2011, 2:13pm)

by tbtech24 (Jun 9th 2011, 9:24am)

3 901

by Wet_Boots

(Jun 9th 2011, 10:09am)

by kxaz145 (May 1st 2009, 2:52pm)

3 1,603

by Wet_Boots

(Jun 3rd 2011, 7:49am)

by Metalman1 (May 23rd 2011, 11:56am)

3 678

by sharon

(May 30th 2011, 12:20pm)

by krantzr (Apr 30th 2011, 8:26am)

3 1,605

by mrfixit

(May 1st 2011, 11:34am)

by stellar495 (Mar 17th 2011, 8:57pm)

3 2,303

by hi.todd

(Mar 20th 2011, 11:03am)

by quick11 (Oct 7th 2010, 10:53am)

3 669

by Wet_Boots

(Oct 23rd 2010, 9:10am)

by dwinmac (Sep 4th 2010, 2:42pm)

3 614

by Wet_Boots

(Sep 5th 2010, 2:55pm)

Show

Statistics:

500 Threads - 1,915 Posts (average 0.37 Posts per Day)