You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by denm31 (Apr 4th 2011, 3:11pm)

6 1,147

by Wet_Boots

(Apr 7th 2011, 1:00pm)

by Fidalgorob (Dec 4th 2010, 12:19pm)

1 583

by mrfixit

(Dec 4th 2010, 1:48pm)

by dwinmac (Sep 4th 2010, 2:42pm)

3 583

by Wet_Boots

(Sep 5th 2010, 2:55pm)

by guy_sparky (Aug 12th 2010, 10:35am)

3 951

by mrfixit

(Aug 12th 2010, 5:12pm)

by Eastern chubbytool (Aug 8th 2010, 2:49pm)

2 1,011

by hi.todd

(Aug 10th 2010, 11:57am)

by Emblazed (Jul 24th 2010, 10:30am)

5 757

by Wet_Boots

(Jul 27th 2010, 10:48am)

by ssherrid (Jul 21st 2010, 12:18am)

0 584

No reply

by slugbugblue (Jul 16th 2010, 6:40am)

2 371

by Wet_Boots

(Jul 17th 2010, 9:11am)

by paul b (Jul 3rd 2010, 10:24am)

1 619

by Wet_Boots

(Jul 6th 2010, 9:21am)

by svsprinklers (May 19th 2010, 9:29pm)

2 1,329

by PhoenixDen

(Jun 24th 2010, 11:27am)

Show

Statistics:

485 Threads - 1,832 Posts (average 0.36 Posts per Day)