You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by boosted50 (Mar 18th 2004, 4:55am)

5 376

by boosted50

(Mar 20th 2004, 1:24pm)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 371

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by water (Oct 23rd 2008, 8:47am)

1 366

by mrfixit

(Oct 23rd 2008, 10:24am)

by grey (Aug 24th 2012, 6:29pm)

1 361

by grey

(Aug 25th 2012, 2:19pm)

by mack (Apr 18th 2012, 8:30pm)

2 359

by mack

(Apr 19th 2012, 12:54pm)

by Emblazed (Jul 24th 2010, 10:30am)

5 356

by Wet_Boots

(Jul 27th 2010, 10:48am)

by Grahpack (Jun 9th 2011, 7:07pm)

1 355

by Wet_Boots

(Jun 9th 2011, 9:05pm)

by jack z (Apr 8th 2012, 10:35am)

1 354

by mrfixit

(Apr 8th 2012, 2:37pm)

by shrpshtr (Apr 26th 2011, 12:32am)

0 354

No reply

by desmo907 (Aug 28th 2012, 3:54pm)

3 350

by desmo907

(Sep 4th 2012, 8:33am)

Show

Statistics:

419 Threads - 1,565 Posts (average 0.35 Posts per Day)