You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Wet_Boots (May 8th 2011, 7:43am)

0 233

No reply

by trapkoch (Jul 5th 2009, 10:20am)

1 233

by mrfixit

(Jul 5th 2009, 12:46pm)

by jbalduf (May 31st 2007, 3:04pm)

1 233

by HooKooDooKu

(Jun 1st 2007, 9:13am)

by fmayerjr (Aug 2nd 2012, 10:47am)

1 234

by Wet_Boots

(Aug 2nd 2012, 2:16pm)

by TheEngineer (Sep 14th 2005, 5:44pm)

4 235

by lush96

(Mar 19th 2006, 8:13pm)

by nowaterflow (Mar 8th 2013, 3:52pm)

3 236

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by PATS (Aug 17th 2005, 2:22am)

1 236

by Wet_Boots

(Aug 17th 2005, 2:45am)

by martinjames10 (Nov 10th 2004, 8:57am)

5 238

by Jazzer K

(Sep 2nd 2005, 6:11pm)

by torodude (Aug 27th 2004, 12:47pm)

1 240

by SprinklerGuy

(Aug 30th 2004, 8:24am)

by pphilt (Oct 9th 2011, 9:55pm)

5 242

by JimmyTheGlove

(Oct 13th 2011, 3:24pm)

Show

Statistics:

430 Threads - 1,626 Posts (average 0.36 Posts per Day)