You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by shellbeach (Sep 27th 2010, 4:18pm)

2 423

by Wet_Boots

(Sep 28th 2010, 1:11pm)

by wingnut (Jul 9th 2009, 10:29pm)

1 423

by mrfixit

(Jul 10th 2009, 2:31pm)

by crazydayz (Oct 17th 2007, 6:33am)

0 424

No reply

by rickesco (Jul 28th 2004, 8:13am)

3 424

by aquamatic

(Jul 29th 2004, 10:36am)

by pete57 (Jun 19th 2007, 6:43pm)

0 425

No reply

by sijaz (Aug 11th 2015, 12:25am)

3 426

by mrfixit

(Aug 11th 2015, 2:35pm)

by slugbugblue (Jul 16th 2010, 6:40am)

2 428

by Wet_Boots

(Jul 17th 2010, 9:11am)

by Lonesomedave (Oct 16th 2015, 7:38am)

1 430

by Wet_Boots

(Oct 16th 2015, 10:46am)

by alf51175 (Aug 1st 2011, 9:53pm)

3 430

by alf51175

(Aug 2nd 2011, 8:02pm)

by lloydlevy (Nov 28th 2011, 11:14am)

3 431

by Wet_Boots

(Nov 29th 2011, 8:22am)

Show

Statistics:

513 Threads - 1,964 Posts (average 0.37 Posts per Day)