You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by grey (Aug 24th 2012, 6:29pm)

1 1,829

by grey

(Aug 25th 2012, 2:19pm)

by BuckeyeBBB (Sep 21st 2016, 6:23pm)

1 151

by mrfixit

(Sep 22nd 2016, 2:38am)

by opsec (Apr 1st 2012, 7:44pm)

2 824

by Wet_Boots

(Apr 2nd 2012, 9:08am)

by Mac54321 (Jul 13th 2011, 10:03am)

1 2,326

by Wet_Boots

(Jul 13th 2011, 11:30am)

by zipcode (Jul 10th 2011, 5:26pm)

2 654

by Mitchgo

(Jul 11th 2011, 12:24am)

by GeorgeBorge21 (Jul 25th 2011, 1:15pm)

2 547

by Mitchgo

(Jul 25th 2011, 11:12pm)

by ddeferra (Jun 7th 2011, 10:46pm)

2 1,234

by ddeferra

(Jun 8th 2011, 6:29pm)

by dse (Jun 8th 2012, 5:58am)

2 653

by Wet_Boots

(Jun 8th 2012, 8:48am)

by rickthedrummer101 (May 11th 2013, 2:26pm)

1 520

by Wet_Boots

(May 11th 2013, 5:08pm)

by JA (May 9th 2010, 11:27am)

7 6,841

by Wet_Boots

(May 3rd 2011, 6:55am)

Show

Statistics:

517 Threads - 1,975 Posts (average 0.37 Posts per Day)