You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by joeywfl (Jun 15th 2015, 8:34am)

1 105

by Wet_Boots

(Jun 15th 2015, 9:02am)

by odiaz1 (May 10th 2012, 10:18am)

1 481

by Wet_Boots

(May 10th 2012, 10:26am)

by 95mmrenegade (Jul 20th 2014, 10:30am)

4 193

by Central Irrigation

(Jul 20th 2014, 2:43pm)

by m collins (Jul 5th 2012, 11:04am)

3 463

by GatorGuy

(Jul 5th 2012, 12:27pm)

by david28 (May 28th 2007, 3:46am)

2 675

by david28

(May 28th 2007, 5:55pm)

by Jeff Nobles (May 21st 2009, 9:40am)

3 685

by hi.todd

(May 22nd 2009, 8:19pm)

by kenttab (May 21st 2012, 5:51pm)

1 1,007

by mrfixit

(May 21st 2012, 8:58pm)

by bdt (Oct 17th 2011, 9:50am)

2 527

by Mitchgo

(Oct 17th 2011, 12:59pm)

by t_shea (Sep 18th 2010, 10:46am)

5 3,105

by Wet_Boots

(Sep 20th 2010, 1:01pm)

by 6pack (May 13th 2015, 8:14pm)

1 147

by Wet_Boots

(May 13th 2015, 8:54pm)



479 Threads - 1,805 Posts (average 0.36 Posts per Day)