You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by KSknight (Aug 17th 2009, 10:53am)

1 691

by bdbengtsson

(May 21st 2010, 5:27pm)

by Don_Mousseau (May 15th 2010, 8:44am)

1 648

by mrfixit

(May 15th 2010, 1:03pm)

by DRegs (May 5th 2010, 5:29pm)

1 334

by Wet_Boots

(May 6th 2010, 2:34pm)

by BVISailor (Oct 31st 2009, 10:11am)

1 830

by worachj

(Oct 31st 2009, 12:47pm)

by ahersman (Sep 30th 2009, 1:37pm)

1 217

by ahersman

(Sep 30th 2009, 6:15pm)

by mharden5 (Jul 11th 2009, 12:45pm)

1 242

by hi.todd

(Jul 11th 2009, 9:27pm)

by melprint (Jul 11th 2009, 9:06am)

1 268

by mrfixit

(Jul 11th 2009, 11:59am)

by wingnut (Jul 9th 2009, 10:29pm)

1 243

by mrfixit

(Jul 10th 2009, 2:31pm)

by trapkoch (Jul 5th 2009, 10:20am)

1 299

by mrfixit

(Jul 5th 2009, 12:46pm)

by lydiaE (Jun 25th 2009, 11:39am)

1 425

by HooKooDooKu

(Jul 1st 2009, 11:31am)

Show

Statistics:

466 Threads - 1,711 Posts (average 0.37 Posts per Day)