You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Gerrit Van de Haar (Jun 5th 2010, 2:40pm)

3 268

by HooKooDooKu

(Jun 9th 2010, 11:12am)

by Merv (May 1st 2010, 3:44pm)

3 386

by mrfixit

(May 31st 2010, 9:47pm)

by Jeff Nobles (May 21st 2009, 9:40am)

3 567

by hi.todd

(May 22nd 2009, 8:19pm)

by kenball27 (May 1st 2009, 1:01pm)

3 2,509

by mrfixit

(May 10th 2009, 1:13pm)

by ArrakeenIrrigator (Sep 14th 2007, 5:52am)

3 845

by edwildesr

(Oct 7th 2007, 6:49pm)

by ArrakeenIrrigator (Sep 14th 2007, 5:48am)

3 286

by Wet_Boots

(Sep 15th 2007, 12:31am)

by Tee Jay (May 17th 2007, 8:38am)

3 237

by Bill Painter

(May 21st 2007, 1:12pm)

by korangu2004 (Aug 16th 2006, 5:56pm)

3 1,121

by jmduke7

(Aug 17th 2006, 3:00pm)

by bobottolini (Jul 10th 2006, 12:27pm)

3 353

by jmduke7

(Aug 16th 2006, 6:30pm)

by wkneis@optonline.net (Apr 9th 2006, 5:52pm)

3 335

by xpedient

(Jul 2nd 2006, 3:34pm)

Show

Statistics:

464 Threads - 1,709 Posts (average 0.37 Posts per Day)