You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by HHicks (Jul 22nd 2011, 4:57pm)

1 845

by Wet_Boots

(Jul 22nd 2011, 6:38pm)

by Mac54321 (Jul 13th 2011, 10:03am)

1 1,094

by Wet_Boots

(Jul 13th 2011, 11:30am)

by ncampbel (Jul 1st 2011, 2:15pm)

1 906

by Mitchgo

(Jul 1st 2011, 9:20pm)

by Grahpack (Jun 9th 2011, 7:07pm)

1 635

by Wet_Boots

(Jun 9th 2011, 9:05pm)

by tbtech24 (Jun 9th 2011, 9:24am)

3 871

by Wet_Boots

(Jun 9th 2011, 10:09am)

by Wet_Boots (May 8th 2011, 7:43am)

0 375

No reply

by krantzr (Apr 30th 2011, 8:26am)

3 1,516

by mrfixit

(May 1st 2011, 11:34am)

by miker (Apr 30th 2011, 12:53pm)

1 553

by Wet_Boots

(Apr 30th 2011, 2:45pm)

by ianmac (Apr 25th 2011, 10:45pm)

1 849

by Wet_Boots

(Apr 26th 2011, 9:20am)

by shrpshtr (Apr 26th 2011, 12:32am)

0 505

No reply

Show

Statistics:

485 Threads - 1,829 Posts (average 0.36 Posts per Day)