You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by harrisst14 (Jun 10th 2012, 6:29pm)

1 598

by mrfixit

(Jun 10th 2012, 8:13pm)

by AdamT (Jun 7th 2012, 12:00pm)

2 174

by AdamT

(Jun 7th 2012, 9:14pm)

by Katy (Jun 1st 2012, 3:41pm)

2 181

by hi.todd

(Jun 1st 2012, 8:55pm)

by tbone136 (May 24th 2012, 9:46am)

0 112

No reply

by kenttab (May 21st 2012, 5:51pm)

1 668

by mrfixit

(May 21st 2012, 8:58pm)

by Cherrybark (May 20th 2012, 6:22pm)

2 297

by GatorGuy

(May 21st 2012, 9:04am)

by stktrader (May 20th 2012, 5:55pm)

4 287

by Wet_Boots

(May 21st 2012, 7:02am)

by odiaz1 (May 10th 2012, 10:18am)

1 352

by Wet_Boots

(May 10th 2012, 10:26am)

by Stu1986 (May 5th 2012, 11:44pm)

3 255

by mrfixit

(May 6th 2012, 1:23pm)

by SpritzCan (Apr 21st 2012, 8:33pm)

2 137

by GatorGuy

(Apr 23rd 2012, 8:47am)

Show

Statistics:

430 Threads - 1,626 Posts (average 0.36 Posts per Day)