You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by ksrmc (Aug 1st 2012, 3:27pm)

6 1,154

by Wet_Boots

(Aug 2nd 2012, 9:31am)

by Bonelawr (Jul 29th 2012, 9:45am)

2 372

by Bonelawr

(Jul 29th 2012, 11:38am)

by nrwe (Jul 19th 2012, 1:57pm)

4 910

by mrfixit

(Jul 20th 2012, 3:06pm)

by sirlar (Jul 20th 2012, 2:40pm)

0 347

No reply

by MEL88 (Jul 19th 2012, 12:20pm)

1 358

by GatorGuy

(Jul 19th 2012, 2:14pm)

by AWCiesiel (Jul 13th 2012, 8:42pm)

1 693

by mrfixit

(Jul 14th 2012, 12:39am)

by Sierra9093 (Jul 5th 2011, 8:06pm)

5 789

by s123mith

(Jul 10th 2012, 5:21am)

by m collins (Jul 5th 2012, 11:04am)

3 1,685

by GatorGuy

(Jul 5th 2012, 12:27pm)

by Lainiest (Jul 2nd 2012, 7:11pm)

2 466

by GatorGuy

(Jul 3rd 2012, 8:00am)

by chrisratz (Jun 27th 2012, 7:40pm)

4 825

by chrisratz

(Jun 29th 2012, 11:18pm)

Show

Statistics:

504 Threads - 1,929 Posts (average 0.37 Posts per Day)