You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by alscarpati (May 20th 2006, 2:02am)

5 400

by alscarpati

(May 21st 2006, 7:02am)

by lily (May 20th 2006, 9:31pm)

4 399

by daniels

(Aug 7th 2007, 11:00am)

by Sierra9093 (Jul 5th 2011, 8:06pm)

5 398

by s123mith

(Jul 10th 2012, 5:21am)

by Jimy (Aug 30th 2011, 11:45am)

4 397

by chrisrlewis78

(Sep 4th 2011, 2:52pm)

by lybrand (Aug 30th 2012, 3:54pm)

1 396

by Wet_Boots

(Aug 30th 2012, 4:50pm)

by Trabecca (Mar 13th 2013, 6:22pm)

7 393

by Trabecca

(Mar 18th 2013, 8:23am)

by tc1458 (Apr 13th 2005, 9:37am)

5 393

by Jazzer K

(Sep 2nd 2005, 6:17pm)

by hudr0004 (Sep 12th 2011, 10:16am)

4 392

by hudr0004

(Oct 24th 2011, 8:38am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 390

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by 13dwf (Sep 7th 2010, 1:03pm)

4 386

by Wet_Boots

(Sep 9th 2010, 8:50pm)

Show

Statistics:

421 Threads - 1,568 Posts (average 0.35 Posts per Day)