You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by ksrmc (Aug 1st 2012, 3:27pm)

6 545

by Wet_Boots

(Aug 2nd 2012, 9:31am)

by Jeff Nobles (May 21st 2009, 9:40am)

3 545

by hi.todd

(May 22nd 2009, 8:19pm)

by csnugg (Jun 26th 2006, 4:10pm)

0 545

No reply

by pstruh (Jun 7th 2007, 7:58pm)

2 544

by mrfixit

(Jun 8th 2007, 9:45pm)

by ruchuck (May 29th 2013, 8:54am)

7 540

by mrfixit

(Jun 2nd 2013, 12:03am)

by denm31 (Apr 4th 2011, 3:11pm)

6 539

by Wet_Boots

(Apr 7th 2011, 1:00pm)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 537

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by Rick Hudspeth (May 31st 2006, 5:13am)

2 537

by Rick Hudspeth

(May 31st 2006, 7:35am)

by mcclurgjw (Sep 13th 2005, 8:00am)

2 533

by mcclurgjw

(Sep 14th 2005, 6:04am)

by david28 (May 28th 2007, 3:46am)

2 529

by david28

(May 28th 2007, 5:55pm)

Show

Statistics:

440 Threads - 1,685 Posts (average 0.36 Posts per Day)