You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by alf51175 (Aug 1st 2011, 9:53pm)

3 339

by alf51175

(Aug 2nd 2011, 8:02pm)

by purdymatthew (Aug 6th 2007, 6:05am)

1 339

by jmduke7

(Aug 7th 2007, 11:20am)

by grph (Aug 31st 2005, 3:56am)

1 340

by Jazzer K

(Sep 2nd 2005, 6:25pm)

by Stanman (Oct 28th 2014, 10:11pm)

5 341

by Wet_Boots

(Oct 30th 2014, 5:08am)

by lloydlevy (Nov 28th 2011, 11:14am)

3 341

by Wet_Boots

(Nov 29th 2011, 8:22am)

by crazydayz (Oct 17th 2007, 6:33am)

0 341

No reply

by Binks (Apr 10th 2013, 1:28am)

1 342

by mrfixit

(Apr 10th 2013, 3:02am)

by glmcolo (Nov 27th 2006, 4:32am)

1 342

by Wet_Boots

(Nov 27th 2006, 6:04am)

by Tee Jay (May 17th 2007, 8:38am)

3 343

by Bill Painter

(May 21st 2007, 1:12pm)

by Moggie (Jun 4th 2011, 10:48am)

1 346

by Mitchgo

(Jun 5th 2011, 1:28pm)



479 Threads - 1,805 Posts (average 0.36 Posts per Day)