You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by SprinklerMaps (Apr 27th 2014, 10:13pm)

0 392

No reply

by Roger Stover (Jun 16th 2009, 11:09am)

4 392

by hi.todd

(Jun 19th 2009, 10:27pm)

by rickesco (Jul 28th 2004, 8:13am)

3 392

by aquamatic

(Jul 29th 2004, 10:36am)

by sbradfor (Jul 20th 2003, 7:40am)

1 392

by Rays Sprinklers

(Jul 20th 2003, 7:49am)

by Lonesomedave (Oct 16th 2015, 7:38am)

1 393

by Wet_Boots

(Oct 16th 2015, 10:46am)

by mharden5 (Jul 11th 2009, 12:45pm)

1 393

by hi.todd

(Jul 11th 2009, 9:27pm)

by Wet_Boots (May 8th 2011, 7:43am)

0 394

No reply

by RodQ (Jul 11th 2010, 12:54pm)

2 394

by hi.todd

(Jul 12th 2010, 12:49pm)

by shellbeach (Sep 27th 2010, 4:18pm)

2 395

by Wet_Boots

(Sep 28th 2010, 1:11pm)

by alf51175 (Aug 1st 2011, 9:53pm)

3 397

by alf51175

(Aug 2nd 2011, 8:02pm)

Show

Statistics:

505 Threads - 1,935 Posts (average 0.37 Posts per Day)