You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by HHicks (Jul 22nd 2011, 4:57pm)

1 624

by Wet_Boots

(Jul 22nd 2011, 6:38pm)

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 191

by Wet_Boots

(Jun 9th 2013, 8:14pm)

by ros (Mar 15th 2012, 7:40pm)

1 392

by hi.todd

(Mar 20th 2012, 9:07pm)

by odiaz1 (May 10th 2012, 10:18am)

1 363

by Wet_Boots

(May 10th 2012, 10:26am)

by 95mmrenegade (Jul 20th 2014, 10:30am)

4 33

by Central Irrigation

(Jul 20th 2014, 2:43pm)

by m collins (Jul 5th 2012, 11:04am)

3 216

by GatorGuy

(Jul 5th 2012, 12:27pm)

by david28 (May 28th 2007, 3:46am)

2 483

by david28

(May 28th 2007, 5:55pm)

by Jeff Nobles (May 21st 2009, 9:40am)

3 496

by hi.todd

(May 22nd 2009, 8:19pm)

by kenttab (May 21st 2012, 5:51pm)

1 701

by mrfixit

(May 21st 2012, 8:58pm)

by bdt (Oct 17th 2011, 9:50am)

2 347

by Mitchgo

(Oct 17th 2011, 12:59pm)

Show

Statistics:

435 Threads - 1,641 Posts (average 0.36 Posts per Day)