You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by porterville cemetery (Nov 1st 2011, 2:23pm)

1 329

by Wet_Boots

(Nov 1st 2011, 3:12pm)

by jerr7 (May 4th 2015, 4:35pm)

2 139

by jerr7

(May 6th 2015, 11:08am)

by Sartenose (Sep 22nd 2012, 2:31pm)

1 683

by Wet_Boots

(Sep 22nd 2012, 10:06pm)

by billinvi (Mar 30th 2007, 3:28pm)

0 230

No reply

by ddak32@yahoo.com (Oct 17th 2012, 3:09pm)

1 834

by Wet_Boots

(Oct 17th 2012, 5:31pm)

by Mikeee (Apr 22nd 2007, 9:24am)

2 1,240

by jmduke7

(Apr 22nd 2007, 2:21pm)

by Roger Stover (Jun 16th 2009, 11:09am)

4 388

by hi.todd

(Jun 19th 2009, 10:27pm)

by Wharfrat (May 16th 2008, 11:43am)

1 471

by mrfixit

(May 16th 2008, 5:43pm)

by pillboy (Jun 8th 2011, 6:40pm)

11 4,957

by Wet_Boots

(Jun 14th 2011, 2:26pm)

by tbatrof (Sep 10th 2011, 7:00pm)

2 444

by mrfixit

(Sep 10th 2011, 10:07pm)

Show

Statistics:

504 Threads - 1,929 Posts (average 0.37 Posts per Day)