You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by bobspitler (Jun 6th 2011, 7:10am)

1 338

by Mitchgo

(Jun 6th 2011, 9:34pm)

by Moggie (Jun 4th 2011, 10:48am)

1 271

by Mitchgo

(Jun 5th 2011, 1:28pm)

by blh (Jun 4th 2011, 12:55pm)

1 364

by Mitchgo

(Jun 4th 2011, 3:32pm)

by runningfreak (May 25th 2011, 7:32pm)

1 231

by Wet_Boots

(May 25th 2011, 8:29pm)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 379

by Mitchgo

(May 9th 2011, 1:04am)

by miker (Apr 30th 2011, 12:53pm)

1 412

by Wet_Boots

(Apr 30th 2011, 2:45pm)

by ianmac (Apr 25th 2011, 10:45pm)

1 656

by Wet_Boots

(Apr 26th 2011, 9:20am)

by jchsmiller (Apr 18th 2011, 11:47am)

1 315

by Wet_Boots

(Apr 20th 2011, 12:27pm)

by joe decoste (Mar 19th 2011, 11:56am)

1 219

by Wet_Boots

(Mar 20th 2011, 7:29am)

by Mitchell (Feb 27th 2011, 2:26pm)

1 402

by hi.todd

(Feb 27th 2011, 4:12pm)

Show

Statistics:

466 Threads - 1,711 Posts (average 0.37 Posts per Day)